Archive

Posts Tagged ‘ocz’

My VMware vSphere Home lab configuration

September 5th, 2012 8 comments

I have always enjoyed running my own home lab for testing and playing around with the latest software and operating systems / hypervisors. Up until recently, it was all hosted on VMware Workstation 8.0 on my home gaming PC, which has an AMD Phenom II x6 (hex core) CPU and 16GB of DDR3 RAM. This has been great, and I still use it, but there are some bits and pieces I still want to be able to play with that are traditionally difficult to do on a single physical machine, such as working with VLANs and taking advantage of hardware feature sets.

 

To that end, I have been slowly building up a physical home lab environment. Here is what I currently have:

Hosts

  • 2 x HP Proliant N40L Microservers (AMD Turion Dual Core processors @ 1.5GHz)
  • 8GB DDR3 1333MHz RAM (2 x 4GB modules)
  • Onboard Gbit NIC
  • PCI-Express 4x HP NC360T Dual Port Gbit NIC as addon card (modifed to low-profile bracket)
  • 250GB local SATA HDD (just used to host the ESXi installations.

Networking

  • As mentioned above, I am using HP NC360T PCI-Express NICs to give me a total of 3 x vmnics per ESXi host.
  • Dell PowerConnect 5324 switch (24 port Gbit managed switch)
  • 1Gbit Powerline Ethernet home plugs to uplink the Dell PowerConnect switch to the home broadband connection. This allows me to keep the lab in a remote location in the house, which keeps the noise away from the living area.

Storage

  • This is a work in progress at the moment, (currently finding the low end 2 x bay home NAS devices are not sufficient for performance, and the more expensive models are too expensive to justify).
  • Repurposed Micro-ATX custom built PC, housed in a Silverstone SG05 micro-ATX chassis running FreeNAS 8.2 (Original build and pics of the chassis here)
  • Intel Core 2 Duo 2.4 GHz processor
  • 4GB DDR2-800 RAM
  • 1 Gbit NIC
  • 1 x 1TB 7200 RPM SATA II drive
  • 1 x 128GB OCZ Vertex 2E SSD (SATA II)
  • As this is temporary, each drive provides 1 x Datastore to the ESXi hosts. I therefore have one large datastore for general VMs, and one fast SSD based datastore for high priority VMs, or VM disks. I am limited by the fact that the Micro-ATX board only has 2 x onboard SATA ports, so I may consider purchasing an addon card to expand these.
  • Storage is presented as NFS. I am currently testing ZFS vs UFS and the use of the SSD drive as a ZFS and zil log / and or cache drive. To make this more reliable, I will need the above mentioned addon card to build redundancy into the system, as I would not like to lose a drive at this time!

Platform / ghetto rack

  • IKEA Lack rack (black) – cheap and expandable : )

 

To do

Currently, one host only has 4GB RAM, I have an 8GB kit waiting to be added to bring both up to 8GB. I also need to add the HP NC360T dual port NIC to this host too as it is a recent addition to the home lab.

On the storage side of things, I just managed to take delivery of 2 x OCZ Vertex 2 128GB SSD drives which I got at bargain prices the other day (£45 each). Once I have expanded SATA connectivity in my Micro-ATX FreeNAS box I will look into adding these drives for some super fast SSD storage expansion.

 

The 2 x 120GB OCZ SSDs to be used for Shared Host Storage

HP NC360T PCI-Express NIC and 8GB RAM kit for the new Microserver

 

Lastly, the Dell PowerConnect 5324 switch I am using still has the original firmware loaded (from 2005). This needs to be updated to the latest version so that I can enable Link Layer Discovery Protocol (LLDP) – which is newly supported with the VMware vSphere 5.0 release on Distributed Virtual Switches. This can help with the configuration and management of network components in an infrastructure, and will mainly serve to allow me to play with this feature in my home lab. I seem to have lost my USB-to-Serial adapter though, so this firmware upgrade will need to wait until I can source a new one off ebay.

 

E8400 Gaming rig build

January 30th, 2009 1 comment

This is an old post from my other site. I thought as it was IT relevant I would clone the small write up I did across to this blog…

I recently bought myself a new rig, consisting of a Coolermaster CM-690 and the following hardware:

Asus P5Q P45 Pro motherboard
Intel E8400 overclocked to 3.6GHz 24/7
OCZ 2GB ATI Heatspreader RAM DDR800 4-4-4-12
Sapphire ATI HD 4870 512MB GDDR5 Graphics card
OCZ GameXstream 600w Power supply
Western Digital 750GB SATAII Hard drive
Logitech G15 Keyboard (orange backlight model)
Logitech MX518 (5 year old mouse that has travelled the world with me!)

For display I chose a 24″ Dell LCD with a native resolution of 1920×1200 and 6ms response time.

My ultimate goal was to build a faster, cooler and quieter PC than the previous one I had in S.A.

Right, so in my last rig I had the pre-built CM-690 L-shaped window panel. This came with the chassis when I bought it, so I was pretty lazy and didn’t change anything. I also had a Coolermaster Aquagate watercooling unit that fitted in 2 x optical drive bays, which had the pump, radiator and everything incorporated, cooling my E8200 on the old rig. Temperatures were not much better than the Zalman 9700LED that I used to have on it and it was quite messy. I also didn’t enjoy the tiny tubing that this unit used, hence my custom kit choice with 1/2″ diameter tubing for this project. I had never built myself a custom watercooling system, so this will be my first. It will also be the first batch of modding I have done in about 10 years! (The last mod I did was on an AMD K6-2 333MHz in an AT case many, many years ago)! That is barring some odd LED, and minor case mods here and there.

Anyway, here is an image of the final product (Case cut, window installed, hardware assembled and modded to fit the watercooling gear. Cables neatened and basically everything finished, barring the watercooling of the graphics card.

final-1

night-shot

I cut a rough pattern out of the top with my jigsaw, this is where the radiator is to be fit:

case-cut

I cabled-sleeved most of the loose / visible wiring throughout the chassis:

cable-sleeving

Next to be cut was the side panel – Masked off the area to be cut, and used the jigsaw once again:

perspex

This is the box of goodies (watercooling hardware) I ordered from Specialtech:

goodies

The waterblock for cooling the CPU:

cpu-block

Shortly after finishing the water components, and tubing, I started the system up for leak testing…

test-run

A few weeks later the graphics card was ready to be added to the watercooling system. This is a Sapphire ATI HD 4870 512MB (GDDR4) card. I had to remove the stock air cooler, and re-apply some new thermal compound. I used Zalman STG-1 thermal paste for this.

4870-air

Here the card is naked, with the old thermal compound applied to the GPU. The card still needed to be cleaned with some pure alcohol to remove the old thermal paste.

4870-naked

Everything installed, Feser one non-conductive cooling fluid in the loop with the system up and running :

final-2

A small update on this build.

Since the original work was finished, I have now upgraded the RAM. I added another 2GB OCZ RAM to give a total of 4GB. I also pushed my original overclock a bit further, and now run the FSB at 445MHz with a CPU multiplier of 9x giving me a total of 4.0GHz on the E8400. The RAM is running a multiplier of 2x overclocking the four modules to 890MHz each, with timings of 4-4-4-12. My Vcore setting for the processor is on around about 1.375 volts, and my RAM is sitting at 2.2 volts which is what I consider a safe 24/7 setting for RAM modules cooled by passive heatsinks. The FSB is set to 1.16 volts for the increase FSB speed to hold stable. I also flashed the 4870′s bios with a custom image, that sets the card’s default core speed to 795mhz (from a default of 750mhz) and the memory to 1100mhz (from a default of 900mhz). I then use Catalyst Control Centre to up the core speed to a further 830mhz for gaming. The PC now runs at these speeds 24/7 and has no stability issues.